Welcome SA Tech Help.

Asking for help

in AG Mobile
by
0 votes
102 views
Iam using since February the AG Rage Android mobile phone. S/N L20150911003273, IMEI1: 353396070012724; IMEI2: 353396070032724; Androi 4.4 kitkat; 1.0GHz processor/512MB RAM.

Since last week, I took out the battery and I put it again, the phone switched on and the show me only AGmobile and is permanently lighting! Nothing else is displayed on the screen. What can I do.

Regards

1 Answer

by (Genius) (10.4m points)
0 votes
Hi. Can you advise if you have attempted a hard reset?
0
by (Genius) (21.7m points)
If not then here are the instructions http://www.satechhelp.co.za/1635/Hard-Reset-Ag-Chrome-Selfie for a hard reset. If these instructions does no work your phone please let us know so we can sort this out on a live chat.

Related questions

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge. ... Do also NOTE that this website is a third party not directly affiliated with any company for which we offer support. If you not satisfied with the provided answer to your question' please use the reply/comment button below the answer section to request further assistance' You might want to add more info to support your question if necessary.
add
...