Welcome SA Tech Help.

Telefunken TELC-73GIQ not booting

in Telefunken TELC-73GIQ
by (User) (700 points)
0 votes
1.9k views
Hi my tablet will not go past the Android logo.  I have tried the above steps as well and the phone switches off and turns on but only gets as far as that logo.

Advise please

1 Answer

by (Genius) (10.4m points)
edited by
0 votes
 
Best answer

Hey Tam.Storey, it sounds like your Telefunken TELC-73GIQ has a corrupted firmware or main software. A fresh software reload will be therefore necessary. A DIY option will require that you have a friend who has a working TELC-73GIQ from which you can take a backup and use that on yours. Please refer here: http://satechhelp.co.za/14261/Flash-Download-Filrmware-Rom-Telefunken-Telc-73giq-Tablet
 

Related questions

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge. ... Do also NOTE that this website is a third party not directly affiliated with any company for which we offer support. If you not satisfied with the provided answer to your question' please use the reply/comment button below the answer section to request further assistance' You might want to add more info to support your question if necessary.
add
...