New questions often answered in 5 minutes.
0 votes
998 views
in ZTE by
My ZTE Z796c just shut off as I was using it, when I tried to it back only but, only had a red light blink. Thinking maybe it needed charged, I plugged it in about 2 hours ago. I'm still only getting a red light. I removed the battery several times, it did nothing. Please help, if you can
related to an answer for: How to hard reset the ZTE Majesty?

1 Answer

0 votes
by Genius (55,165,340 points)
edited by
So Far i know the red blicking/flashing as notification light for new massages, low batthery and missed calles. But in your case i think your battery might has been drained out. Try the instructions below
1. Remove the battery' press and hold the power button for 5 Sec
2. Put the charger without the battery
3. Press and hold the power button again for 10-15 sec.
4. Put the battery and the charger back to the phone for atlist 5 minuts, do not power the phone on during the  5 Minuts
5. After the 5 minuts switch on the phone while on charger. Please let me know when you done.
Please feel free to comment for further assistance

Related questions

13,043 questions

12,083 answers

4,842 comments

14,575 users

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge.
...