like dislike
2,687 views
in AG Chrome Ultra by
My AG Chrome Ultra is stuck on the boot screen. Any one know how a can reload the stock firmware in the place of this that seems corrupt. I am an IT technician so following up should not be hard. Also, where can I download a firmware or stock ROM pack? Thanks a lot.

1 Answer

like dislike
by Genius (34,144,140 points)
edited by
 
Best answer

Hey Geek - Follow the below steps to try and flash/download a stock ROM or firmware onto your AG Chrome Ultra device.

  1. First download and install/extract the following: SP Flash Tool
  2. Also download and extract the AG Chrome Ultra's firmware or ROM from [ROM Download]. 
  3. Install the MediaTek Preloader USB VCOM drivers as per the tutorial here
  4. Launch the SP Tool from the extracted folder
  5. Click 'Scatter-Loading' > browse to and locate the scatter file from your extracted firmware or ROM folder files
  6. Make sure 'Preloader' NOT ticked :)
  7. Then click on the Download button
  8. Connect the AG Chrome Ultra to the computer via a compatible USB cable so computer can detect and connect to its system
  9. The flashing process should then start with progress bars (red being the first) and you should get a green cycle with a white tick and the text 'Download OK' when the flashing is completed. At which stage you can safely disconnect the your AG Chrome Ultra device and power it on for a re-setup.

NOTE: We can flash the device for you remotely (over the internet) for R100 If you are not comfortable flashing the device yourself. Read more  here

by User (100 points)
Good day Kervin I would like you help my AG Chrome Ultra is bricked and I can't unbrick it. I tried flashing it but no luck it doesn't want to go through and flash. And at first my AG was booting and stops at the boot logo so I made a mistake buy flashing it with a wrong firmware by doing that my AG went blank and it doesn't boot at all, I even have the correct Firmware I got here and bought but still I can't flash it to return to it's normal way again please help so i can fix this please
by Genius (34,144,140 points)
Do you get any error message when trying to flash again? Something like 0x0FC or 4032? If yes, then you will need to try 'Format all + Download' on the SP Flash Tool. If the issue persist, then you need to open the device and lookup the board ID and share that. Read more on your situation here: http://satechhelp.co.za/18362/Brom-Error-_ft_enable_dram_fail-0xfc0

Related questions

1 like dislike
1 answer 364 views
like dislike
1 answer 1,791 views

12,511 questions

11,600 answers

4,588 comments

8,414 users

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge.
...