New questions often answered in 5 minutes.
0 votes
829 views
in Vodafone Smart Tab 3G by
Hello. I recently confirmed a Vodafone Smart Tab 3G to download and install an official OTA.

 But now the tablet is stuck at  UPRADING ANDROID - OPTIMIZING APP 1 of 57. I have the firmware but the tablet is going straight to charging mode. i tried all the button combinations and still it goes to charging mode. I removed the battery with the purpose of reconnecting it after i click the DOWNLOAD button on the SPFLASHTOOL and connecting the usb cable. But still it goes to charging mode. I am now convinced that it is not a drivers issue, because the windows machine has all the mtk vcom drivers, and UBUNTU 16.04 has SPFLASHTOOL properly installed and i can flash any other mtk device on it but not this VODAFONE SMART TAB 3G.

I also went as far as to install android kitchen, create a working folder, used the tab's system.img and boot.img for the project, did not customize anything on that rom, and then optimizeed the rom for high ram performance, packed it to an update.zip and finally i signed it and put it on the sd card which went into the VODAFONE SMART TAB 3G. When i try to update from zip (stock recovery) in order to get rid of the changes made by the OTA, it just says ERROR - INSTALLATION ABORTED. I know when i'm beat.

I need your help please.

1 Answer

0 votes
by Genius (34,235,140 points)
selected by
 
Best answer
Hi. This sound entirely driver borne. What Windows version do you have? Also, unless if you have transferred data with the USB cable you are using with success in the past, I strongly suggest you try a different one. Let us know.
by User (100 points)
But i have another exact same VODAFONE SMART TAB 3G and it can communicate with the Windows 7 machine and the UBUNTU 16.04 machine that i use. That is why i am convinced that it is not a drivers issue. Besides adding udev rules, i never had to do anything else to get adb or fastboot working on UBUNTU 16.04. This convinces me that it is not a drivers issue.
by Genius (34,235,140 points)
The SP Tool does not use the normal 'booted device' USB driver to communicate with a device on boot-mode. It strickly needs the MTK VCOM driver for the purpose.
by User (100 points)
in UBUNTU there is no need to install mtk vcom drivers. I have flashed different phones using SPFLASHTOOL for linux, and i have always had success. The windows machine, on the other hand, has all the MTK VCOM drivers installed and i have flashed several mtk devices on that windows machine. But with this tablet, there is no feedback from the linux or windows machine whatsoever. It's like i am using a usb charging cable.
by Genius (34,235,140 points)
moved by
OK yes I never flashed from a Linux environment and never knew the driver circumstances. From all that you have disclosed, it would then either be hardware or that the update tempered with the Preloader. With the help of jumpers on the board however, you can try and force the tab into boot mode (provided it is indeed a corrupt preloader). It sound more hardware borne though if you are certain the the USB cable is valid.
by Genius (34,235,140 points)
Like we sadly tend to do, I had not read all the details on your question and I see how the drivers were indeed   already isolated out since you can flash other MTKs with no issues. And yes my 2nd answer had to be a comment but made an answer in error :)
by User (100 points)
No problem. Thanks.

13,041 questions

12,082 answers

4,839 comments

14,356 users

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge.
...