Welcome to SA Tech Help
In the answer section below are both steps on how to reload the firmware of the Telefunken TEL-73GIQS with a board ID of K03_V2.5.2 D4 and an SP7731GEA Spreadtrum chipsets.
in Telefunken Tablets by (Genius) (10.4m points)
edited by
0 0
my board ID is K03_V2.5.2 D2..getting error user canceled message
1 0
When i try u flash Telefunken TEL-73GIQS  showing this error emulating port ???
1 0
Hi. You may need to try a different PC
1 0
i already check other pc  still same
1 0
Ohk you may then be looking at a hardware fault as both ROM as tested for flashing.
1 0

1 Answer

1 like 0 dislike
Best answer

The .pac ROM is available here: http://www.saroms.co.za/product/telefunken-tel-73giqs-firmwarerom/ and below are flashing steps via SPD_Upgrade_Tool_R4.0.0001 which is a lot like ReseachDownloader. Request, download and extract the ROM

  1. Download the SPD_Upgrade_Tool_R4.0.0001 from here: https://mega.nz/#!bZZUFRhQ!aXSEUrVos-jDYiw8O6MNvIvbZ-ia34QuoUmK2oLiqSo and extract it
  2. Install the Spreadtrum drivers as per the Guide here
  3. Then open up the extracted SPD_Upgrade_Tool_R4.0.0001 folder twice > then double-click the file with a black chip and two green arrows icon
  4. With the flasher loaded > click on the gear icon on the far left > browse to and load the  *.pac ROM/firmware file by double clicking on it - it can take up to a minute or two
  5. Click the button with two gear icons (2nd from the left) > untick both NV_W and NV_WCN items
  6. Then click the Play like icon (Start Downloading)
  7. And then connect the TEL-73GIQS tablet with volume down held down
  8. The downloading should start with a blue bar - at which stage you can release the volume down key > different partitioned will be flashed and you get a green 'Passed' when all is done
  9. At which stage click the Stop icon (Square)
  10. Disconnect and power up the TEL-73GIQS 

NB. It can take a little longer to boot up after a flash (no more than 5 minutes though).

by (Genius) (10.4m points)
selected by
it not flashing with spd tool
1 0
Hi, I am having trouble to flash my device. I have set up everything, the only problem is when I try to connect the tablet, I am holding the down key and connecting to the computer and after about 5 minutes of continuous pressing the telefunken blue screen comes up, i see a charging 0% screen after that and then it turns off again, but without being picked up by the flasher
1 0
Your issue may be related to drivers or signature enforcement if you are on a 64 bit system. But 0% is not good - you need the tablet at about 50%+ of charge. Are you able to turn the tablet off - you may need to do so by removing and reattaching 1 battery cable

Related questions

1 answer
asked Aug 31, 2016 in Other by Vunene (Genius) (10.4m points) | 3.5k views
SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge. ... Do also NOTE that this website is a third party not directly affiliated with any company for which we offer support. If you not satisfied with the provided answer to your question' please use the reply/comment button below the answer section to request further assistance' You might want to add more info to support your question if necessary.