New questions often answered in 5 minutes.
My mobicel v4 does not pass the logo during startup' the phone is frozen on the logo' i have to remove the battery to switch it off.

2 Answers

by (Genius) (20.7m points)
selected by
+1 vote
 
Best answer
Hello
You have to hard reset your mobicel v4. Please see instructions on this link https://www.satechhelp.co.za/27334/how-to-hard-reset-mobicel-v1-or-v2?show=27334#q27334
0
by
edited
Ive got the same problem with my mobicel Astro...

I need help plesss
by (Professional) (354k points)
+2 votes
Probably, yu need to load  software, if reset fails...thom wll provide u with link for software purchase
0
by (Master) (902k points)
If  a hard reset does not do then flashing is your last option. Please let us know the results.

Related questions

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge. ... Do also NOTE that this website is a third party not directly affiliated with any company for which we offer support. If you not satisfied with the provided answer to your question' please use the reply/comment button below the answer section to request further assistance' You might want to add more info to support your question if necessary.
add
...