Welcome SA Tech Help.
TP LINK 3.75G HSUPA USB ADAPTER from Matrix Warehouse worked well when it was first setup but now it keeps on disconnecting after about 2 minutes of being connected. When this happens, I have to remove the modem and connect the USB dongle for it to connect again to disconnect after 2 minutes.

1 Answer

by (Genius) (10.4m points)
0 votes
 
Best answer

Hey Toon, the following are things you can try :-

  • Uninstall the dongle's driver and software, restart the computer and then reinstall the pack and observe - if the issue persist,
  • Try the TP-Link 3G dongle in a different computer and observe - if the issue persist,
  • Then it must most likely indicate a hardware (firmware) failure - in which case I will suggest you take it back to Matrix Warehouse for exchange as these normally carry a year or two of warranty. 

Related questions

SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge. ... Do also NOTE that this website is a third party not directly affiliated with any company for which we offer support. If you not satisfied with the provided answer to your question' please use the reply/comment button below the answer section to request further assistance' You might want to add more info to support your question if necessary.
add
...