Welcome to SA Tech Help
in AG Boost by
retagged by

1 Answer

0 like 0 dislike
Best answer
Hi. Sorry for the delayed reply. Try and reset it as per the steps here http://www.satechhelp.co.za/4971/Common-Hard-Reset-Steps-Android-Powered-Devices and let us know. Also, do you know of a friend who owns the same model? Otherwise, we have a firmware you can try reloading in the place of the current one which may be corrupt. Let us know.
by (Genius) (10.4m points)
edited by

Related questions

1 answer
asked May 3, 2016 in AG Boost by meluleki | 378 views
1 answer
asked Feb 16, 2017 in AG Boost by Rhyno | 243 views
1 answer
asked May 23, 2016 in AG Boost by anonymous | 444 views
1 answer
asked Apr 3, 2016 in AG Boost by wizzy mluh | 204 views
1 answer
asked Feb 8, 2016 in AG Boost by Viper (User) (700 points) | 480 views
1 answer
asked Dec 31, 2015 in AG Boost by anonymous | 655 views
SA Tech Help Q2A, where you can ask any question and receive answers from other members of the community'. SA Tech Help Q&A was created to be a free resource linking people with tech questions to experts who could provide answers. Since our launch in 2014, we have grown from a simple Q&A web site to providing additional help such as loans,roms, pricing information and more. All is completely free of charge. ... Do also NOTE that this website is a third party not directly affiliated with any company for which we offer support. If you not satisfied with the provided answer to your question' please use the reply/comment button below the answer section to request further assistance' You might want to add more info to support your question if necessary.